Subdivision surface not working?

Doing the udemy course, trying to make a wine glass. When I add the subdivision surface modifier, nothing happens. I have already merged vertices to a distance of 0.01 m. If I try to take that distance any bigger, I end up messing up the stem of the wine glass. So, I can’t figure out why the modifier isn’t working.


Hey Erin! Could you post a screenshot here of the issue?

Not exactly sure what you wanted a screenshot of, so I grabbed the full window, along with an image of just the modifier box in case you just need to see that part. If there’s something else you want me to take a picture of specifically, please let me know. I didn’t see a spot to specify the size of the upload, so hopefully the parts you need are readable. :slight_smile:

That’s strange. Might grab a screen shot with viewport SDS at 2 or 3 and one in edit mode. I see no reason that isn’t working.

maybe increase the viewport as mentioned. 

Yeah try increasing the viewport number

Sorry, I had the viewport number higher previously, but had been messing with some of the settings trying to figure out what could be causing it not to work. 

I now increased the number for viewport to 4. I didn’t see any changes when I did that. I don’t think there’s anything else I need to do to apply the changes, right? 

I got an email mentioning a reply asking if I had applied scale in Object Mode before adding the modifier. I don’t see that reply here, but I hadn’t. I removed the modifier, did ctrl-A, selected scale, and then added the modifier again, and I’m still not seeing any change. I don’t think I had done that accidentally before I posted, because while I may have hit ctrl-A instead of A to select all, I wouldn’t have selected any of the options… 


It’s strange indeed… One possible cause I can think is that your model might have creases that will ‘negate’ the subsurf, try disabling the ‘use creases’ option and see if it works. Also might be helpful if you can show the wireframe too (go into Edit mode). Should that still fail, make a new object like a cube and try the modifier on it, or try it on a new file.

hmmmmmmm at this point I don’t know. Seems like a bug. Could you upload your .blend to dropbox or google drive so I can take a look at it directly?


And, my blender version is: Blender 2.80 (sub 75), running on linux. 

Thanks for looking at it. I will probably re-create it from scratch again, but even if it works then, it would be good to figure out where it went wrong this time. 

hmmmmmmmmm very strange. I tried the SS modifier and it affects it but in a very strange way. Have you tried to remake the glass from scratch?

I just checked the file you posted. The normals are not consistent, after correcting the normals the subdivision works as it is supposed to. Go into edit mode, “A” to select all of the mesh then press Shift+N and that will recalculate normals to the outside of the mesh.  

Strange I tried recalculating normals and it hadn’t done anything. Interesting

The normals are different so they need to be facing the same direction for the subdivision surface modifier to work properly. That is why you are getting that pinched look. Here is a quick video showing the fix. 

Thank you! Any idea what could cause the normals problem? 

I am planning on making it from scratch but also have figured this is a good time to learn how to solve issues in blender

The normals problem sometimes comes from extruding and they get flipped inside out. But do what Steve said and it should fix the issue. go into edit mode, select everything and go to mesh –> normals and recalculate to outside. Or hit F3 and search for recalculate normals

Yes, as Alex pointed out. Extrusions sometimes will cause normals to come in backward like that. Normally when there is pinching issues like that it is either due to normals being opposite in areas, or disconnected verticies or doubles. Glad you got it sorted out now and able to move ahead with modeling and learning blender.

Okay, I must be missing something really basic here. I finally got a chance to look into things, and recalculating normals didn’t do anything useful for me. I decided to recreate a brand new wineglass, and try again, and I’m still not getting anything from subdivision surface???  

I’m also not seeing the pinched look that FlyingBanana showed in the video, but I’m honestly not seeing any change happening when I run subdivision surface. 

I’m going to upload another blend file to see if maybe it’s something else I’m missing. This one, I’ve done a lot less debugging/poking at stuff with, so maybe I’ve messed fewer things up?

When doing the spin, does it matter which direction you spin it? 

Blend File:

Thanks for looking!