Something I found using Geforce Experience / Nvidia Driver


I wanted to inform people as I found it was affecting my computer and Blender, Nvidia Experience is a addition to Nvidia Drivers, if you have a nvidia card you may want to check this. Nvidia Experience has a overlay mode, any shotcut it shares with Blender such as Alt-R, experience will override automatically, so you have to go in and disable or remap shotcuts of nvidia experience. I personally don’t need it , so I disabled it. here are some shots of how to do so.

First go to bottom right of windows , and theres icons or a little arrow that opens up into icons and right click the Nvidia icon you will get this menu
Screenshot 2024-04-12 172940

Then Left click Geforce Experience
it will open up into a window like this, on the right there is a gear icon and click that

will open into settings>general you will see IN-GAME OVERLAY with a switch that will probably be green ,click that switch and turn it off , that’s it , you can close out of all windows. Then Blender will act as normal.

This may help some people as it did me, so thought I would share.
Screenshot 2024-04-12 174555


The Alt+R is the bane of my Blender existence. I am to lazy and leave it as it is. If only my renders could operate at 144htz