Smoke not rendering.

I’ve set up my smoke simulation how I wanted to look in the render viewport, but it doesn’t appear and it’s doesn’t appear in a render. I have the smoke simulation baked. Anyone have anyhow this can be fixed?

Your domain object didn’t get disabled for render did it? That would allow it to show in the viewport but not in a viewport render.

Could you also show your shader editor node setup for the smoke?

I don’t think it got disabled. I don’t have a shader for the smoke. I just tampered with the settings from the physics tabs. Unless it needs one.

With your domain selected is there a node already setup there? If not then you will need to add a principal volume node and hook it up to the volume. You should then be able to see it in the viewport rendering.

thank you steve, that worked. I just needed the principle volume node for the domain shader.

Glad to see you got it worked out ed. :slight_smile: