Problem rigging an object that is a parent to another object

I have a model I have created, which has a few different parts. There’s the body, and then there are some eyes, a nose, and a mouth, which are separate objects. The body is the parent of the other objects. In object / edit mode, if I move/rotate the body, the eyes and such move along with the body just like they are supposed to. 

So, I rigged up a quick armature for the model and started playing around in Pose mode, but then I hit a big snag. In pose mode, the eyes/nose/mouth refuse to stay with the rest of the body! My poor teddy bear keeps losing his eyes!

Teddy happens to like having his eyes on his face rather than floating in the air next to him. How can I keep his eyes where they belong???  I thought parenting would do it, but apparently it isn’t working. 


Hey Erin! Happy to help. Yes you would do that with parenting and it should work with it being parented. Can you post a screenshot here so I can see the issue?

Okay, so, the first picture is just in object mode. the second is in pose mode when I tilted his head. If you look in the scene collection dialog on the right, you can see that I have the body parented to the armature and the eyes and such parented to the body. 


Huh… second picture didn’t seem to come across. hopefully it will play nicer now

Try this. Make sure you are in pose mode, then select the eyes in object mode and shift select the head bone in pose mode and hit CTRL+P and set parent to bone

Trying to figure out how to do this. In pose mode, I can’t seem to select the eyes. In object mode, I can select the eyes, but then I need to select the entire armature in order to switch to pose mode. I tried clicking the eye, then ctrl-clicking the armature, then switching to pose mode and selecting the head bone and parenting it, and it seems to mostly work, I think. So I need to do that with all the parts of the model?

I guess for some reason it can’t just hold onto the parenting from the modeling… Seems like it ought to be able to use the previous parenting instead of needing everything separate. For this model, it’s just a few extra things that need parenting, but in a more complex model, it seems it would very quickly end up with a very tedious process trying to hook a whole bunch of small pieces to the correct parts of the armature, unless there’s a simpler way to connect everything. 

Yes that is the way to do it. Select your eyes, select the armature hit CTRL+Tab to go into pose mode, select head bone and parent :slight_smile: not sure what happened before, could have an an error in parenting, a bug or just a simple mistake but if that works, awesome! :slight_smile:

ah… I see now that while I can’t seem to grab the items in the viewport in pose mode, I can grab them in the scene explorer while in pose mode to simplify things a bit. But it still seems slightly frustrating, because I have to lose all my object hierarchy when doing it. For example, the threads for the buttons are children of my button eyes. But now, after I make the eyes children of the armature, the threads don’t follow the eyes any more. So, I need to make the thread children of the armature, but now if I go to move the eyes in object mode, I have to make sure that I grab the threads as well as the eyes, or they get out of sync?  Same type of issue with the curve that the mouth is following, which is a child of the thread for the mouth. 

It’s interesting, but it seems like an odd design decision to have armatures not follow existing parentage and insisting on everything being an immediate child of the armature or specific bones in the armature. Or maybe I just need to be joining everything instead of parenting it??

Hmmm… So, it’s not as severe as it was, but Teddy is still having some issues. One eye seems to be sinking into his fur, and the items that were originally made using bezier curves (mouth (made from a curve modifier on a screw) and the threads for the button eyes(initially a curve with a bevel that has been converted to mesh)) don’t seem to want to behave correctly when I tilt his head. 

Make sure to apply the scale and location to the objects by hitting CTRL+A. Also if it keeps behaving strange, could you upload your .blend to dropbox or google drive and share link here and I will take a look for you

Thanks. I applied scale, location and rotation and I’m still seeing the same problem. I’m sure I’m probably just missing something silly here, but I can’t seem to figure out what it is! Thanks for the help!!!

Tried joining the various pieces to the bear’s body, and it didn’t seem to fix the problem… 

Wish I knew enough to help.