I'm relatively new to blender, I've made this rover and I'm stuck when it comes to textures, The goal is to have a finish similar to the images below, Would love some help!

3 Likes

Looks super sick Joel. Can you post some reference images of the type of texture you are going for?

1 Like

Yeah sure! something like this

2 Likes

So what exactly are you trying to do? Are you talking about the edgewear on it or scratches? Or the panels themselves etc?

1 Like

Well my model doesn’t have alot of panels, Basically yeah the edgewear and scratches, Basically a look that it’s lasted a while but not too long, Even if the overall edgewear isn’t there it’s fine, But I really would like to get that kind of surface texture

2 Likes

Here you go this node setup can be used for edgewear and scratches. Make sure to be in cycles in rendered viewport shading mode as the bevel node only works there. Also for the scratches they will only be elongated on the y and z since those are the only ones scaled. If you need elongated scratches in all dimensions you’ll need to do a different setup, just let me know. Give this a shot though and you can mess around with the different settings
Scratches.blend (1002.6 KB)

1 Like

Thanks alot! I’ll mess around with it, will give you some feedback soon

2 Likes

Alright I just noticed one thing, I don’t know if something is wrong on my end or not but, The textures render in CPU mode, but not on GPU mode, in the viewport or a rendered image, Any idea what the issue is?

2 Likes

Are you still in Cycles with GPU render? Could you try to go to a brand new file and go to file → append and append all your objects to a new scene and try there. If it still doesn’t work, if you can share your .blend will take a look

1 Like

Yep I tried all of that, It’s the same blend file you attached but I will send it anyway
Scratches.blend (1002.6 KB)

2 Likes

I thought it was on your file it didn’t work. Try selecting / deselecting the “Open Shading Language” box

image

1 Like

I don’t have OPL since I use an AMD card, Do you think there’s something in the node setup that doesn’t support? I have an RX6600

2 Likes

It’s hard to save as mine doesn’t do GPU so I can’t test it out. Check this forum here as there might be a solution: rendering - Why are there scenes that will not render on GPU but will render fine on CPU? - Blender Stack Exchange

1 Like

I couldn’t find a proper solution, Thanks for all the help on the textures! I’ll figure something out

2 Likes

For someone “Relativelly new”, this is very good. I have to assume you created everything in this scene?

1 Like

Well the design is not mine, It’s from the movie “Martian” I have my own design which is still in development, But I thought the Martian Rover would be a good design to learn the modeling process of blender, and it has helped A lot. I’m really struggling with textures though, All the textures in that scene are basically from blender kit with some dust just manually painted on the surfaces. But for the scene I have in mind I would really love to go for a texture like the second image attached in this thread, Alex has helped me alot here with his node setup but unfortunately it doesn’t work on my machine, But hopefully there’s enough tutorials out there to help me get to my vision

1 Like

Joel, AMD cards are not really supported in Blender3D very well , With the newer version of Blender, they included a new render option aimed toward AMD cards shown here. You can try this option if you are using newer version of Blender. However being a newer feature, I am unsure of the stability of the render option but its atleast a option to try. Oh sorry, its in preferences.
Screenshot 2024-01-27 012336

1 Like

Yep I am using that option, It still doesn’t work, It’s just unfortunate on my side, Thanks for the help though.

1 Like

I want to also say, its a good challenge, the front gonna be a little tricky good mix of shapes and techniques you will need to learn that will advance your skill, good luck, make sure to post when it’s done, I am sure everyone would like to see it.

2 Likes

Will do, Thanks!

1 Like