I can't color anything EDIT: Resolved!

Hi. I’m completely new to Blender and have been using a Udemy course on low poly modeling to try and get started, but for some reason I can’t color anything like in the materials video. I’m clicking on the object I want to color (the TV), then clicking the “beach ball” icon, then clicking new, and then last changing the base color, but for some reason when I go into material view or rendered view my color won’t show up Cry

I know there’s probably some dumb tiny detail I’m overlooking here, but can anyone help?

EDIT: Problem is resolved now! My graphics driver was out of date so I updated it.

Very nice room! Love it. I am almost sure that this is a graphics card issue… Have you tried updating your drivers? Can you upload your .blend here with the documents icon on the forum reply so I can take a look?

So apparently there’s a “Blender” file and a “BLEND1” file? I put the Blender one here so I hope it’s the right one >.<

I don’t know anything about graphics cards or drivers though.


The file works for me. Although there is a glitch in the material preview for me.

Have your tried changing render engine over to Cycles?

I have seen that on some computers. They don’t like evee for some reason but works in Cycles.

There is something wrong with that purple texture. Even though you have a different color selected it is just a pink.

I just opened your file on my work computer which is pretty crappy. The viewport shading never works on this system but I can preview.

I just deleted that pink material and created new and it then allowed me to add. Just do that I think.

Here are 3 screenshots when I first opened your scene. When I previewed it. Then changing the textures.

Your modelling of the scene is very nice. I like it.