Dragon in the works

Still messing with this dragon. The armature/rig is slow process. Model is from DAZ studio since I tried three times to build a dragon from scratch and just couldn’t get it to work.

This way I can alter an already made mesh and color it different if I want.

Working on face rig now.

Now this I want to see animated! :smiley:

Anybody got any ideas why this armature won’t parent to the mesh? It keeps giving/telling me an error saying its having trouble calculating for more than one bone.

When I tried to assign the head to the head bone vertex group the head did move but it also canceled out the IK in the neck.

This rig is from Ali Arango’s red dragon tutorial. Why it won’t parent to this mesh I don’t know. Though, I did use the meta rig cat as a starter rather than bone by bone.

I guess this means I have to start all over again bone by bone. I am NOT going to weight paint this thing.

when the Object consists of 2 or more separated (not connected) meshes which intersect. This could be solved by fixing the mesh topology, like connecting the intersecting meshes into one single mesh and by fixing your model to avoid the intersecting areas.

When the object has duplicate vertices. This can be solved by removing doubles in Edit Mode ( keyboard shortcut “W” -> Remove Doubles) It’s probably the double vertices

If those don’t work, If you want I can take a look. Just upload the .blend to dropbox or google drive and I can check

Hi. Thanks. I might have you look. I’ll try the vertice thing. I think what it is though is that the mesh is just waayyyyyy too dense so I am in the process of doing a retopo job. Its not as bad as I thought retopo would be, but this is a big creature for my first try at it.

I thought I’d do that and then use normal maps or something but then I have to make the normal maps because there are none and then the original textures from Daz Studio won’t work because the topology has changed so I’ll have to make new ‘skin’.

LOL. This is becoming a large project.

But, I’ll try the ideas you got here. The rig/armature whatever the proper term is all done and I’d like to see this thing move.

I did try making the wings a separate object and they parented to their wing bones just fine. But the body still gave me problems so it is something in the body mesh.


Having trouble finding Remove Doubles in 2.8 used an old video to find some over lapping geometry in wings would like to clean it up. Can’t find remove doubles.

And where is Make Manifold?

Remove doubles if you go into edit mode and right click is now renamed to merge vertices

I messed with the dragon in DAZ Studio to try to lower the polycount. I got it waaaaayyyyyy down from 400,000 something to 100,000 something but, I got these weird blue lines. Not sure what this is or how to fix it.

Anybody got any ideas?

I exported from DAZ as a Wavefront.obj and imported as a Wavefront.obj because that gives the best mesh and the materials will display correctly.

Looks like there is double vertices or that it’s ripped there? If you select a vertex there and hit G, does it move and create a hole in the mesh? If so you need to merge them together. And they may be too far to use the remove doubles feature so do it manually. Otherwise I’m not quite sure…

The blue lines is due to the edges are marked as ‘sharp’, which will make the edges appear sharp when you use edge split (with ‘sharp edegs’ turned on) + subsurf modifier. It can be removed by selecting the edges (or select all if you dont want any sharp edges), press Ctrl+E, and select ‘Clear Sharp’. Hope this helps. Slight Smile

Duh. Can’t believe I didn’t think of that lol! Thanks Po!

That worked! Woohoo! Now I can do that to a few other imported models. Thanks.

Nope, that still don’t make the mesh parent to the armature. Aparently the mesh is too dense or something.

I dunno.

Some success! I exported a lower poly dragon from DAZ and parented a simple rig and it worked so this means that the mesh of the original dragon I was using was too dense or bad or something.

Now my question is how do I make a normal map or whatever it is called to make this lower poly dragon look more like the one I started with.

More work but at least I got, hopefully, the parenting issue solved.

YAY, got the mesh parented to the armature/rig. The density of the mesh was what was the problem. I discovered a setting for low resolution in DAZ Studio where this dragon comes from and that made all the difference.

Now I get to make textures and play with doing some simple animations.

How does one save animations to be used in other blend files?

Test animation in EVEE. EVEE renders fast.

Need a better way to judge the speed of final animation.

Dragon was made into a brush and supposed to displace the snow using Dynamic Paint but it don’t work. I guess either the dragon is too high poly or the armature is messing it up or whatever.

Wanted to make a fun animation of a dragon making ‘snow angels’.


That is awesome cats! Nicely done on the animation. As for using animations in other .blends all you need to do is go into the .blend and go to file –> append and append the model+armature and you can have it in a new .blend