Bridge complete at last-better render

Used Cycles to render-Eevee seems incompatible with my GTX computer.  Looking for ways to reduce noise. 

Be sure you have denoiser turned on in cycles. It will greatly reduce noise. You can also lower the bounces in light paths to reduce noise and render time. Another trick is to turn off caustics if they aren’t required. Blender Guru has a good video for optimizing render settings. It’s on a much older version, but still applies greatly.